Letsencrypt - certbot-auto

Suite de mon billet d’il y a quelques jours puisque malgré la mise à jour de l’utilitaire de renouvellement et le renouvellement des dits certificats j’ai encore reçu avant-hier un mail d’avertissement de Letsencrypt :

Hello,

Action may be required to prevent your Let’s Encrypt certificate renewals from breaking.

If you already received a similar e-mail, this one contains updated information.

Your Let’s Encrypt client used ACME TLS-SNI-01 domain validation to issue a certificate in the past 60 days. Below is a list of names and IP addresses validated (max of one per account):

open-time.net (***.***.***.***) on 2018-11-21

TLS-SNI-01 validation is reaching end-of-life. It will stop working temporarily on February 13th, 2019, and permanently on March 13th, 2019. Any certificates issued before then will continue to work for 90 days after their issuance date.

You need to update your ACME client to use an alternative validation method (HTTP-01, DNS-01 or TLS-ALPN-01) before this date or your certificate renewals will break and existing certificates will start to expire.

Our staging environment already has TLS-SNI-01 disabled, so if you’d like to test whether your system will work after February 13, you can run against staging: https://letsencrypt.org/docs/staging-environment/

If you’re a Certbot user, you can find more information here: https://community.letsencrypt.org/t/how-to-stop-using-tls-sni-01-with-certbot/83210

Our forum has many threads on this topic. Please search to see if your question has been answered, then open a new thread if it has not: https://community.letsencrypt.org/

For more information about the TLS-SNI-01 end-of-life please see our API announcement: https://community.letsencrypt.org/t/february-13-2019-end-of-life-for-all-tls-sni-01-validation-support/74209

Thank you,
Let’s Encrypt Staff

Du coup je ne comprends plus ce qu’il se passe vu que le certificat en question a été renouvelé le 20 janvier, ce que vous pouvez d’ailleurs vérifier vous-même pour ce site et j’ai pourtant à nouveau l’avertissement.

certbot-auto est à jour (version 0.30), pas de trace de TLS-SNI-01 dans les fichiers de configuration de renouvellement, j’avoue être plus que perplexe !

Si quelqu’un a des lumières à m’apporter, il sera le bienvenu !

PS : Accessoirement j’ai reçu le même mail, à la même date, pour le certificat du café des blogueurs (instance Mastodon), lui aussi renouvelé depuis !

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant une syntaxe wiki simplifiée.

Ajouter un rétrolien

URL de rétrolien : https://open-time.net/trackback/14078

Haut de page