C'est un sketch !

Sur les Internet j’avise un article qui cause de npm-gui, qui permet de visualiser dans un navigateur les différentes versions installées et potentiellement pouvant être mises à jour d’un projet.

Ça tombe bien, je suis quelqu’un qui aime bien visualiser les choses, même si le terminal ne me rebute pas, bien au contraire.

Bref, je lance comme préconisé :

npx npm-gui

Qui permet d’installer temporairement et de lancer l’outil, sauf que :

npm WARN npm npm does not support Node.js v14.16.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9, 10.
npm WARN npm You can find the latest version at https://nodejs.org/

Et pourtant npm-gui est maintenu, sa dernière release a moins d’un mois, et mes versions de node et npm sont à jour :

node -v
v14.16.0
npm -v
7.8.0

Donc voilà, j’utilise des trucs trop récents, ou bien il y a autre chose qui fout le dawa, aucune idée.


Après avoir un peu fouillé, j’ai fini par trouver qu’un package.json vide dans le répertoire utilisateur foutait le dawa, j’ai lancé un npm update à tout hasard et hop c’est retombé en marche ; me demandez pas pourquoi ;-)

npm-gui : affichage dans le navigateur, avr. 2021
npm-gui : affichage dans le navigateur

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant la syntaxe Markdown Extra.

Ajouter un rétrolien

URL de rétrolien : https://open-time.net/trackback/14942

Haut de page