Attention !

Releases Dotclear jusqu'à la 2.26.1, juin 2023

Une petite version de maintenance, habituelle après une version majeure et qui règle quelques problèmes rencontrés depuis.

La prochaine version majeure (2.27) est prévue pour mi-août, ça sera d’ailleurs l’occasion de fêter les 20 ans de Dotclear et sachez que cette version sera la dernière à supporter encore PHP 7.4.

À partir de la 2.28 qui sera publiée à la fin de l’année (mi-novembre a priori) il faudra avoir a minima PHP 8.1 pour fonctionner.

Vous pouvez d’ores et déjà vous y préparer en basculant sur cette version, voire encore mieux sur la 8.2 puisque ça fait quelques versions que Dotclear la supporte bien !

Voilà le contenu du billet d’annonce de la 2.26.1 sur le blog Dotclear où j’informe que la version 2.28, la version majeure qui suivra celle de mi-août prochain, nécessitera a minima PHP 8.11.

Alors je sais que certain·e·s vont tiquer, que d’autres vont argumenter que Wordpress est toujours compatible avec PHP 7.4, que … et patati et patata.

J’entends mais comme on veut moderniser le code de Dotclear — et j’assume tout à fait le fait de laisser penser que c’est une décision unilatérale de ma part —, à un moment il faut savoir dire stop et sauter le pas.

Parce que pour de vrai, c’est beaucoup plus amusant pour nous développeurs de pouvoir utiliser les avancées récentes du langage plutôt que de devoir se contraindre à conserver des vieilleries, et comme on fait tout ça pour le fun… Vous voyez l’idée ?

Till then enjoy and have fun!


  1. Et pas PHP 8.0 qui est déjà en mode Security fixes only ! ↩︎

Ajouter un commentaire

Les champs suivis d'un * sont obligatoires

Les commentaires peuvent être formatés en utilisant la syntaxe Markdown Extra.

Ajouter un rétrolien

URL de rétrolien : https://open-time.net/trackback/15732

Haut de page