jQuery, il en reste

Pour la 2.17, on va passer de la version 3.4.1 à la version 3.5.1 (des deux côtés, administration et public), avec en parallèle un passage de la version 3.1.0 à la version 3.3.1 de la bibliothèque jQuery-migrate qui avertit, en mode développement, les utilisations obsolètes de jQuery.

Au passage je vais probablement basculer notre vieille version de jQuery autocomplete, qui date de 2009, à celle de jQuery UI, plus récente ; cela dit, je m’interroge aussi sur l’avenir de jQuery UI vu que cette bibliothèque n’est plus maintenue depuis quelques temps (2 ans ½ déjà).

Je sens que ça va pas être simple de s’en passer sans devoir ré-écrire pas mal de choses dans l’admin…

Bref, du jQuery, il va en rester dans Dotclear, et pour encore pas mal de temps.

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant la syntaxe Markdown.

Ajouter un rétrolien

URL de rétrolien : https://open-time.net/trackback/14657

Haut de page